<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head profile="http://gmpg.org/xfn/11">
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

	<title>Walking Randomly &raquo; Free mathcad alternative, SMath Studio, updated to v0.85</title>
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0 - all posts" href="http://feeds.feedburner.com/WalkingRandomly" />
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0 - all comments" href="http://www.walkingrandomly.com/?feed=comments-rss2" />
	<link rel="pingback" href="http://www.walkingrandomly.com/xmlrpc.php" />

	<!-- style START -->
	<link rel="stylesheet" href="http://www.walkingrandomly.com/wp-content/themes/elegant-box/style.css" type="text/css" media="screen" />
		<!--[if IE]>
		<link rel="stylesheet" href="http://www.walkingrandomly.com/wp-content/themes/elegant-box/ie.css" type="text/css" media="screen" />
	<![endif]-->

	<!-- default style -->
			<link rel="stylesheet" href="http://www.walkingrandomly.com/wp-content/themes/elegant-box/styles/blue/default.css" type="text/css" media="screen" title="blue" />
		<link rel="stylesheet" href="http://www.walkingrandomly.com/wp-content/themes/elegant-box/styles/blue/global.css" type="text/css" media="screen" />
	
	<!-- others styles -->
	<!-- style END -->

	<!-- javascript START -->
		<script type="text/javascript" src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/js/base.js"></script>
	<script type="text/javascript" src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/js/menu.js"></script>
	<!-- javascript END -->

		<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Walking Randomly &raquo; Free mathcad alternative, SMath Studio, updated to v0.85 Comments Feed" href="http://www.walkingrandomly.com/?feed=rss2&#038;p=1676" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.walkingrandomly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.2"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-quicklatex-format-css'  href='http://www.walkingrandomly.com/wp-content/plugins/wp-quicklatex/css/quicklatex-format.css?ver=4.6.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-syntax-css-css'  href='http://www.walkingrandomly.com/wp-content/themes/elegant-box/wp-syntax.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://www.walkingrandomly.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.walkingrandomly.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.4.2' type='text/css' media='all' />
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-content/plugins/wp-quicklatex/js/wp-quicklatex-frontend.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='http://www.walkingrandomly.com/?rest_route=/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.walkingrandomly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.walkingrandomly.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='RationalQ &#8211; Testing for rationals in Mathematica' href='http://www.walkingrandomly.com/?p=1659' />
<link rel='next' title='NASA releases first images from upgraded Hubble' href='http://www.walkingrandomly.com/?p=1691' />
<meta name="generator" content="WordPress 4.6.2" />
<link rel="canonical" href="http://www.walkingrandomly.com/?p=1676&#038;cpage=1#comments" />
<link rel='shortlink' href='http://wp.me/p3swhs-r2' />
<link rel="alternate" type="application/json+oembed" href="http://www.walkingrandomly.com/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.walkingrandomly.com%2F%3Fp%3D1676" />
<link rel="alternate" type="text/xml+oembed" href="http://www.walkingrandomly.com/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.walkingrandomly.com%2F%3Fp%3D1676&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Free mathcad alternative, SMath Studio, updated to v0.85" />
<meta property="og:url" content="http://www.walkingrandomly.com/?p=1676" />
<meta property="og:description" content="Smath Studio is a freeware alternative to Mathcad developed by Andrey Ivashov for Windows, Linux and Windows Mobile.  The latest release, version 0.85, was made available yesterday for all platform…" />
<meta property="article:published_time" content="2009-09-02T16:15:10+00:00" />
<meta property="article:modified_time" content="2010-04-03T07:31:46+00:00" />
<meta property="og:site_name" content="Walking Randomly" />
<meta property="og:image" content="http://www.walkingrandomly.com/images/pocket/smath_linux.png" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
<style>.ios7.web-app-mode.has-fixed header{ background-color: rgba(3,122,221,.88);}</style></head>


<body>
	<!-- header START -->
	<div id="header">
		<div class="inner">
			<div class="content">
				<div class="caption">
					<h1 id="title"><a href="http://www.walkingrandomly.com/" title="Because it&#8217;s more fun than getting there in a straight line.">Walking Randomly</a></h1>
					<div id="tagline">Because it&#8217;s more fun than getting there in a straight line.</div>
				</div>

				<!-- search box -->
									<form action="http://www.walkingrandomly.com/" id="search_box" method="get">
						<div id="searchbox">
							<input type="text" id="searchtxt" class="textfield" name="s" value="" />
						</div>
					</form>
				<script type="text/javascript">
//<![CDATA[
	var searchbox = document.getElementById("searchbox");
	var searchtxt = document.getElementById("searchtxt");
	var tiptext = "Type text to search here...";
	if(searchtxt.value == "" || searchtxt.value == tiptext) {
		searchtxt.className += " searchtip";
		searchtxt.value = tiptext;
	}
	searchtxt.onfocus = function(e) {
		if(searchtxt.value == tiptext) {
			searchtxt.value = "";
			searchtxt.className = searchtxt.className.replace(" searchtip", "");
		}
	}
	searchtxt.onblur = function(e) {
		if(searchtxt.value == "") {
			searchtxt.className += " searchtip";
			searchtxt.value = tiptext;
		}
	}
//]]>
</script>

				<!-- navigation START -->
				<ul id="navigation">

					<li class="page_item"><a href="http://www.walkingrandomly.com/">Home</a></li>
					<li class="page_item page-item-2"><a href="http://www.walkingrandomly.com/?page_id=2">About Me</a></li>
<li class="page_item page-item-502"><a href="http://www.walkingrandomly.com/?page_id=502">Highlights</a></li>
<li class="page_item page-item-2055"><a href="http://www.walkingrandomly.com/?page_id=2055">Contact</a></li>
<li class="page_item page-item-5122"><a href="http://www.walkingrandomly.com/?page_id=5122">Testimonials</a></li>
					<li>
						<a rel="external nofollow" title="Follow me!" id="twitter" href="http://twitter.com/WalkingRandomly/"><img src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/images/transparent.gif" alt="Twitter" /></a>
					</li>
											<li id="subscribe">
						<a rel="external nofollow" title="Subscribe to this blog..." id="feed" href="http://feeds.feedburner.com/WalkingRandomly"><img src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/images/transparent.gif" alt="RSS feed" /></a>
					</li>

				</ul>
				<!-- navigation END -->

			</div>
		</div>
	</div>
	<!-- header END -->

	<div id="container">
		<div id="content">
			<div id="main">

		
			<div class="post">
				<div class="title">
					<h2>Free mathcad alternative, SMath Studio, updated to v0.85</h2>
					<div class="fixed"></div>
				</div>

				<div class="info">
					
					<span>September 2nd, 2009</span>
											<span> | Categories: <a href="http://www.walkingrandomly.com/?cat=4" rel="category">math software</a>, <a href="http://www.walkingrandomly.com/?cat=17" rel="category">mathcad</a></span>
																<span> | Tags: </span>
					
					<div class="fixed"></div>
				</div>

				<div class="content">
					<p>Smath Studio is a freeware alternative to <a href="http://www.ptc.com/appserver/mkt/products/home.jsp?k=3901">Mathcad</a> developed by Andrey Ivashov for Windows, Linux and Windows Mobile.  The latest release, <a href="http://en.smath.info/forum/default.aspx?g=posts&amp;t=202">version 0.85</a>, was made available yesterday for all platforms and includes a lot of new functionality combined with a set of bug-fixes.  A small selection of the improvements is shown below but you should head over to the<a href="http://en.smath.info/forum/default.aspx?g=posts&amp;t=202"> SMath forum</a> to see the full list of changes</p>
<ul>
<li>Every page now has its own thread for evaluation &#8211; The user can evaluate pages even if evaluation of one of them in progress;</li>
<li>Multi-threading implemented for the Plot Controls;</li>
<li>Added ability to convert English symbols of the Math and Text Controls to Greek characters with a Ctrl+G keystroke;</li>
<li>New functions implemented: eval(..), polyroots(..), reverse(..), sort(..), rsort(..), csort(..), normi(..), norm1(..), norme(..), linterp(..), cinterp(..) and ainterp(..);</li>
<li>Functions for(..) and while(..) condition evaluating improved;</li>
<li>Added support for Infinity into Symbolic Library;</li>
<li>Function if(..) can be used in symbolic calculations now;</li>
<li>Native support of functions added: abs(..), trunc(..), mod(..), round(..) in Symbolic Library;</li>
<li>Composition of Logarithms simplification added into Symbolic Library;</li>
<li>Danish translation added;</li>
</ul>
<p style="text-align: center;"><img class="aligncenter" src="http://www.walkingrandomly.com/images/pocket/smath_linux.png" alt="Smath studio on Linux" /></p>
<p>SMath Studio is an extremely promising project that has already caught the interest of many Mathcad users (it even has <strong>basic</strong> compatibility with Mathcad&#8217;s file format) and is well worth the download.  Let me know if you try it out.</p>
<p><strong>More about free mathematical software from Walking Randomly<br />
</strong></p>
<ul>
<li><a href="http://www.walkingrandomly.com/?p=2079">Maxima Tutorial &#8211; plotting direction fields for 1st order ODEs</a></li>
<li><a href="http://www.walkingrandomly.com/?p=1879">Interactive Fourier Series with SAGE math</a></li>
</ul>
<p><strong>Update 3rd April 2010: version 0.85 is now out of date.  <a href="http://en.smath.info/forum/default.aspx?g=topics&amp;f=12">Click here</a> for the latest version of SMath Studio.</strong></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-1676" class="share-twitter sd-button share-icon no-text" href="http://www.walkingrandomly.com/?p=1676&amp;share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-1676" class="share-facebook sd-button share-icon no-text" href="http://www.walkingrandomly.com/?p=1676&amp;share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-1676" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.walkingrandomly.com/?p=1676&amp;share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>					<div class="fixed"></div>
				</div>

				<div class="comments comments_single">
					<a href="#respond">Leave a comment</a>
											 | <a href="http://www.walkingrandomly.com/wp-trackback.php?p=1676" rel="trackback">Trackback</a>
									</div>

				<!-- related posts START -->
								<!-- related posts END -->
			</div>


<script type="text/javascript" src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/js/comment.js"></script>

	<!-- comments START -->
	<ol class="commentlist">
			<li class="comment " id="comment-17508">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://0.gravatar.com/avatar/3b782ebb44a9b498cdc6a37613e37db4?s=24&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/3b782ebb44a9b498cdc6a37613e37db4?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<a id="commentauthor-17508" href="http://www.croaxis.com" rel="external nofollow">
											Mathcad CroAxis											</a>
									</div>
				<div class="date">November 20th, 2009 at 15:39</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-17508', 'comment-17508', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-17508', 'comment-17508', 'commentbody-17508', 'comment');">Quote</a> | 
								<a href="#comment-17508">#1</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-17508"><p>SMath Studio? We never heard of it, yet it looks very promising at first glance.<br />
I bookmark this site as I am at work yet I will definetly download this tool and give it a brief try.</p>
<p>Altogether, even if this software is not better than Mathcad, we will post a good review about it on our blogsite.</p>
<p>All the best</p>
<p>CroAxis</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-22272">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://1.gravatar.com/avatar/72cbc4e5d9b3369f5e2b5756353b9871?s=24&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/72cbc4e5d9b3369f5e2b5756353b9871?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<span id="commentauthor-22272">
											Elekes Karoly											</span>
									</div>
				<div class="date">March 31st, 2010 at 15:46</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-22272', 'comment-22272', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-22272', 'comment-22272', 'commentbody-22272', 'comment');">Quote</a> | 
								<a href="#comment-22272">#2</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-22272"><p>Wery good job. The user interface works just like mathcad.I thik the functions are good enough for everyday use for a standart user, engineer. For the complete replacement of matchad I would like to have units in the program. I think its wery important to have at least the basic SI units. m,g,t,N,Pa etc.<br />
(please excuse my bad english)</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-22555">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://0.gravatar.com/avatar/f169909e67458df9036075ad7b86931c?s=24&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/f169909e67458df9036075ad7b86931c?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<span id="commentauthor-22555">
											bbei											</span>
									</div>
				<div class="date">April 5th, 2010 at 15:07</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-22555', 'comment-22555', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-22555', 'comment-22555', 'commentbody-22555', 'comment');">Quote</a> | 
								<a href="#comment-22555">#3</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-22555"><p>I&#8217;ve tried it, but not to my satisfaction.  It still lacks a lot of features, most importantly, it&#8217;s not unit aware.</p>
<p>There&#8217;s still no good alternative to Mathcad.</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment  admincomment" id="comment-22604">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://2.gravatar.com/avatar/2507e43d0e1aefefd6088453b3ea8c04?s=24&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/2507e43d0e1aefefd6088453b3ea8c04?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<a id="commentauthor-22604" href="http://www.walkingrandomly.com" rel="external nofollow">
											Mike Croucher											</a>
									</div>
				<div class="date">April 6th, 2010 at 14:43</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-22604', 'comment-22604', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-22604', 'comment-22604', 'commentbody-22604', 'comment');">Quote</a> | 
								<a href="#comment-22604">#4</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-22604"><p>Hi bbei</p>
<p>It&#8217;s unit aware now :)<br />
<a href="http://www.walkingrandomly.com/?p=2470" rel="nofollow">http://www.walkingrandomly.com/?p=2470</a></p>
<p>Rather than simply saying &#8216;it lacks features&#8217; it is better to say exactly what it does lack.  That way the developer has a chance of fixing it.</p>
<p>Cheers,<br />
Mike</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-25244">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://1.gravatar.com/avatar/aaef40d908de2cea51dcad051641e182?s=24&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/aaef40d908de2cea51dcad051641e182?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<span id="commentauthor-25244">
											Joshua											</span>
									</div>
				<div class="date">June 5th, 2010 at 03:29</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-25244', 'comment-25244', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-25244', 'comment-25244', 'commentbody-25244', 'comment');">Quote</a> | 
								<a href="#comment-25244">#5</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-25244"><p>There is a free as in freedom project to make OOo be like mathcad (and more) look at <a href="http://sourceforge.net/projects/comppad/" rel="nofollow">http://sourceforge.net/projects/comppad/</a></p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-34865">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://2.gravatar.com/avatar/21929783771d23c8f0e0d357416b61f4?s=24&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/21929783771d23c8f0e0d357416b61f4?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<span id="commentauthor-34865">
											tsgrue											</span>
									</div>
				<div class="date">October 11th, 2010 at 00:03</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-34865', 'comment-34865', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-34865', 'comment-34865', 'commentbody-34865', 'comment');">Quote</a> | 
								<a href="#comment-34865">#6</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-34865"><p>SMath Studio now has units (SI and BritImp). It is an excellent software application and the developer gives prompt and direct responses to questions and suggestions &#8211; far, far better support than I have seen from ANY commercial software vendor (engineering or other)&#8230;</p>
<p>tsgrue</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-39494">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://2.gravatar.com/avatar/8e726fbe83142bafc21f1bd83dc1a1d6?s=24&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/8e726fbe83142bafc21f1bd83dc1a1d6?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<a id="commentauthor-39494" href="http://www.rexx.com" rel="external nofollow">
											Johannes Rexx											</a>
									</div>
				<div class="date">November 21st, 2010 at 09:01</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-39494', 'comment-39494', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-39494', 'comment-39494', 'commentbody-39494', 'comment');">Quote</a> | 
								<a href="#comment-39494">#7</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-39494"><p><a href="#comment-25244" rel="nofollow">@Joshua </a><br />
@Joshua I tried comppad but from all appearances it&#8217;s just a math expression layout tool, it is not a live mathematical spreadsheet like MathCAD.</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-55682">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://1.gravatar.com/avatar/a1544738baf5de4bbd417764ed162986?s=24&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/a1544738baf5de4bbd417764ed162986?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<span id="commentauthor-55682">
											Mo											</span>
									</div>
				<div class="date">January 27th, 2011 at 04:41</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-55682', 'comment-55682', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-55682', 'comment-55682', 'commentbody-55682', 'comment');">Quote</a> | 
								<a href="#comment-55682">#8</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-55682"><p>Tried TK Solver ?</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-65893">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://1.gravatar.com/avatar/49fd680821864abdcd55028f4db43578?s=24&#038;d=mm&#038;r=g' srcset='http://1.gravatar.com/avatar/49fd680821864abdcd55028f4db43578?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<span id="commentauthor-65893">
											Luigi											</span>
									</div>
				<div class="date">March 17th, 2011 at 16:53</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-65893', 'comment-65893', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-65893', 'comment-65893', 'commentbody-65893', 'comment');">Quote</a> | 
								<a href="#comment-65893">#9</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-65893"><p>Hello all,<br />
thanks for the tip, I&#8217;ve downloaded SMath and it&#8217;s just fine!<br />
I was looking for some software able to handle very complex formulas for modeling my system (and with a easier interface then Matlab) and this fits exactly with what I was looking for!</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-128788">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://2.gravatar.com/avatar/25e82afd74880aa0771fd0b4443fb128?s=24&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/25e82afd74880aa0771fd0b4443fb128?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<span id="commentauthor-128788">
											Neal											</span>
									</div>
				<div class="date">January 2nd, 2012 at 07:32</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-128788', 'comment-128788', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-128788', 'comment-128788', 'commentbody-128788', 'comment');">Quote</a> | 
								<a href="#comment-128788">#10</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-128788"><p>Greetings,<br />
Delighted to finally see some competition for PTC MathCad.  Before PTC bought Mathsoft, MathCad could be had for a reasonable price but that is history now.</p>
<p>I would like to see some beefed up graphics for plotting:  Control for axes ranges and a log scale option.</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-438404">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://2.gravatar.com/avatar/849e5800ec62a1a993bfd47a690b2c1d?s=24&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/849e5800ec62a1a993bfd47a690b2c1d?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<span id="commentauthor-438404">
											Ross A											</span>
									</div>
				<div class="date">January 16th, 2013 at 02:29</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-438404', 'comment-438404', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-438404', 'comment-438404', 'commentbody-438404', 'comment');">Quote</a> | 
								<a href="#comment-438404">#11</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-438404"><p>interesting stuff&#8230; Can it export MathCAD format files, for edit in MathCAD 14 and 15? This is what could ultimately make it unbeatable. Good to see SI units too but does it do unit conversion, ie imperial to metric (live selection as in MathCAD 14 on?)</p>
<p>keep up the good work.. :)</p>
</div>
		</div>

</li><!-- #comment-## -->
	<li class="comment " id="comment-2406520">
		<div class="userinfo">
			<div class="userpic"><img alt='' src='http://0.gravatar.com/avatar/9b762f1d87a29d9e2fda2677f7cb6112?s=24&#038;d=mm&#038;r=g' srcset='http://0.gravatar.com/avatar/9b762f1d87a29d9e2fda2677f7cb6112?s=48&amp;d=mm&amp;r=g 2x' class='avatar avatar-24 photo' height='24' width='24' /></div>			<div class="usertext">
				<div class="username">
											<span id="commentauthor-2406520">
											Tedd											</span>
									</div>
				<div class="date">January 19th, 2017 at 18:21</div>
			</div>
			<div class="count">
									<a href="javascript:void(0);" onclick="CMT.reply('commentauthor-2406520', 'comment-2406520', 'comment');">Reply</a> | 
								<a href="javascript:void(0);" onclick="CMT.quote('commentauthor-2406520', 'comment-2406520', 'commentbody-2406520', 'comment');">Quote</a> | 
								<a href="#comment-2406520">#12</a>
			</div>
			<div class="fixed"></div>
		</div>
		<div class="comment_text">
			
			<div id="commentbody-2406520"><p>sMath handles units really well now, including seamlessly converting between SI and other units. You can use mixed units in the same expression if you want to. (Not sure why you would, but just to demonstrate how flexible it is.) It has most Imperial units, plus you can define your own units if the units you need aren&#8217;t pre-programed.</p>
</div>
		</div>

</li><!-- #comment-## -->
	</ol>
	<!-- comments END -->

	<!-- comments navi START -->
		<!-- comments navi END -->

	<!-- trackback START -->
		<!-- trackback END -->


	<div id="respond">
	<form action="http://www.walkingrandomly.com/wp-comments-post.php" method="post" id="commentform">

	<!-- comment info -->
	<div id="comment_header">
		<div id="comment_info">
							
				<div id="author_info">
					<div class="row">
						<input type="text" name="author" id="author" class="textfield" value="" size="24" tabindex="1" />
						<label for="author" class="small">Name </label>
					</div>
					<div class="row">
						<input type="text" name="email" id="email" class="textfield" value="" size="24" tabindex="2" />
						<label for="email" class="small">E-Mail (will not be published) </label>
					</div>
					<div class="row">
						<input type="text" name="url" id="url" class="textfield" value="" size="24" tabindex="3" />
						<label for="url" class="small">Website</label>
					</div>
				</div>

				
					</div>
	</div>

	<!-- comment input -->
	<textarea name="comment" id="comment" tabindex="4" rows="8" cols="50"></textarea>

	<!-- comment submit and rss -->
	<div id="submitbox">
		<div id="comments_rss">
			<a href="http://www.walkingrandomly.com/?feed=comments-rss2">
				<span class="feed">Subscribe to comments feed</span>
			</a>
		</div>

		<div class="act">
							<a rel="nofollow" id="cancel-comment-reply-link" href="/?p=1676&amp;cpage=1#respond" style="display:none;">Cancel</a>						<input name="submit" type="submit" id="submit" class="button" tabindex="5" value="Submit Comment" />
		</div>
		
		<input type="hidden" name="comment_post_ID" value="1676" />
					<input type='hidden' name='comment_post_ID' value='1676' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
				<div class="fixed"></div>
	</div>

	<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5ef6e90de0" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="59"/></p>	</form>
	</div>

	

			

	</div>

	<!-- sidebar START -->
<div id="sidebar">

<!-- Style Switcher START -->
<!-- Style Switcher END -->

		<!-- showcase -->
		
		<ul id="widgets">

<li class="widget widget_categories"><h3>Categories</h3>		<ul>
	<li class="cat-item cat-item-35"><a href="http://www.walkingrandomly.com/?cat=35" >Android</a> (15)
</li>
	<li class="cat-item cat-item-75"><a href="http://www.walkingrandomly.com/?cat=75" >Apple</a> (4)
</li>
	<li class="cat-item cat-item-20"><a href="http://www.walkingrandomly.com/?cat=20" >applications</a> (14)
</li>
	<li class="cat-item cat-item-38"><a href="http://www.walkingrandomly.com/?cat=38" >Books</a> (6)
</li>
	<li class="cat-item cat-item-65"><a href="http://www.walkingrandomly.com/?cat=65" >C/C++</a> (5)
</li>
	<li class="cat-item cat-item-37"><a href="http://www.walkingrandomly.com/?cat=37" >Carnival of Math</a> (25)
</li>
	<li class="cat-item cat-item-16"><a href="http://www.walkingrandomly.com/?cat=16" >Chemistry</a> (2)
</li>
	<li class="cat-item cat-item-48"><a href="http://www.walkingrandomly.com/?cat=48" >Condor</a> (6)
</li>
	<li class="cat-item cat-item-71"><a href="http://www.walkingrandomly.com/?cat=71" >control theory</a> (2)
</li>
	<li class="cat-item cat-item-44"><a href="http://www.walkingrandomly.com/?cat=44" >CUDA</a> (13)
</li>
	<li class="cat-item cat-item-58"><a href="http://www.walkingrandomly.com/?cat=58" >Financial Math</a> (3)
</li>
	<li class="cat-item cat-item-34"><a href="http://www.walkingrandomly.com/?cat=34" >Fortran</a> (3)
</li>
	<li class="cat-item cat-item-46"><a href="http://www.walkingrandomly.com/?cat=46" >Fractals</a> (6)
</li>
	<li class="cat-item cat-item-40"><a href="http://www.walkingrandomly.com/?cat=40" >Free software</a> (12)
</li>
	<li class="cat-item cat-item-13"><a href="http://www.walkingrandomly.com/?cat=13" >games</a> (13)
</li>
	<li class="cat-item cat-item-6"><a href="http://www.walkingrandomly.com/?cat=6" >general math</a> (137)
</li>
	<li class="cat-item cat-item-51"><a href="http://www.walkingrandomly.com/?cat=51" >GPU</a> (16)
</li>
	<li class="cat-item cat-item-49"><a href="http://www.walkingrandomly.com/?cat=49" >Guest posts</a> (9)
</li>
	<li class="cat-item cat-item-68"><a href="http://www.walkingrandomly.com/?cat=68" >HPC</a> (8)
</li>
	<li class="cat-item cat-item-43"><a href="http://www.walkingrandomly.com/?cat=43" >iPad</a> (9)
</li>
	<li class="cat-item cat-item-27"><a href="http://www.walkingrandomly.com/?cat=27" >iPhone</a> (11)
</li>
	<li class="cat-item cat-item-14"><a href="http://www.walkingrandomly.com/?cat=14" >java</a> (3)
</li>
	<li class="cat-item cat-item-59"><a href="http://www.walkingrandomly.com/?cat=59" >Julia</a> (5)
</li>
	<li class="cat-item cat-item-45"><a href="http://www.walkingrandomly.com/?cat=45" >just for fun</a> (30)
</li>
	<li class="cat-item cat-item-3"><a href="http://www.walkingrandomly.com/?cat=3" >Latex</a> (5)
</li>
	<li class="cat-item cat-item-73"><a href="http://www.walkingrandomly.com/?cat=73" >Linear Algebra</a> (4)
</li>
	<li class="cat-item cat-item-5"><a href="http://www.walkingrandomly.com/?cat=5" >Linux</a> (40)
</li>
	<li class="cat-item cat-item-26"><a href="http://www.walkingrandomly.com/?cat=26" >Mac OS X</a> (8)
</li>
	<li class="cat-item cat-item-52"><a href="http://www.walkingrandomly.com/?cat=52" >Making Mathematica Faster</a> (2)
</li>
	<li class="cat-item cat-item-53"><a href="http://www.walkingrandomly.com/?cat=53" >Making MATLAB faster</a> (16)
</li>
	<li class="cat-item cat-item-25"><a href="http://www.walkingrandomly.com/?cat=25" >Maple</a> (23)
</li>
	<li class="cat-item cat-item-4"><a href="http://www.walkingrandomly.com/?cat=4" >math software</a> (217)
</li>
	<li class="cat-item cat-item-17"><a href="http://www.walkingrandomly.com/?cat=17" >mathcad</a> (16)
</li>
	<li class="cat-item cat-item-8"><a href="http://www.walkingrandomly.com/?cat=8" >mathematica</a> (105)
</li>
	<li class="cat-item cat-item-11"><a href="http://www.walkingrandomly.com/?cat=11" >matlab</a> (135)
</li>
	<li class="cat-item cat-item-39"><a href="http://www.walkingrandomly.com/?cat=39" >Maxima</a> (2)
</li>
	<li class="cat-item cat-item-56"><a href="http://www.walkingrandomly.com/?cat=56" >Microsoft</a> (1)
</li>
	<li class="cat-item cat-item-55"><a href="http://www.walkingrandomly.com/?cat=55" >Mobile Mathematics</a> (15)
</li>
	<li class="cat-item cat-item-47"><a href="http://www.walkingrandomly.com/?cat=47" >Month of Math Software</a> (30)
</li>
	<li class="cat-item cat-item-28"><a href="http://www.walkingrandomly.com/?cat=28" >NAG Library</a> (32)
</li>
	<li class="cat-item cat-item-61"><a href="http://www.walkingrandomly.com/?cat=61" >natural language</a> (2)
</li>
	<li class="cat-item cat-item-76"><a href="http://www.walkingrandomly.com/?cat=76" >Numerics</a> (3)
</li>
	<li class="cat-item cat-item-78"><a href="http://www.walkingrandomly.com/?cat=78" >Open Data Science</a> (7)
</li>
	<li class="cat-item cat-item-32"><a href="http://www.walkingrandomly.com/?cat=32" >Open Source</a> (23)
</li>
	<li class="cat-item cat-item-50"><a href="http://www.walkingrandomly.com/?cat=50" >OpenCL</a> (5)
</li>
	<li class="cat-item cat-item-41"><a href="http://www.walkingrandomly.com/?cat=41" >parallel programming</a> (18)
</li>
	<li class="cat-item cat-item-19"><a href="http://www.walkingrandomly.com/?cat=19" >physics</a> (9)
</li>
	<li class="cat-item cat-item-9"><a href="http://www.walkingrandomly.com/?cat=9" >pocket pc</a> (9)
</li>
	<li class="cat-item cat-item-72"><a href="http://www.walkingrandomly.com/?cat=72" >Powershell</a> (1)
</li>
	<li class="cat-item cat-item-54"><a href="http://www.walkingrandomly.com/?cat=54" >probability</a> (1)
</li>
	<li class="cat-item cat-item-21"><a href="http://www.walkingrandomly.com/?cat=21" >Problem of the week</a> (12)
</li>
	<li class="cat-item cat-item-7"><a href="http://www.walkingrandomly.com/?cat=7" >programming</a> (150)
</li>
	<li class="cat-item cat-item-31"><a href="http://www.walkingrandomly.com/?cat=31" >python</a> (43)
</li>
	<li class="cat-item cat-item-36"><a href="http://www.walkingrandomly.com/?cat=36" >R</a> (15)
</li>
	<li class="cat-item cat-item-63"><a href="http://www.walkingrandomly.com/?cat=63" >random numbers</a> (7)
</li>
	<li class="cat-item cat-item-74"><a href="http://www.walkingrandomly.com/?cat=74" >raspberry pi</a> (1)
</li>
	<li class="cat-item cat-item-10"><a href="http://www.walkingrandomly.com/?cat=10" >retro computers</a> (6)
</li>
	<li class="cat-item cat-item-80"><a href="http://www.walkingrandomly.com/?cat=80" >RSE</a> (29)
</li>
	<li class="cat-item cat-item-24"><a href="http://www.walkingrandomly.com/?cat=24" >sage interactions</a> (13)
</li>
	<li class="cat-item cat-item-12"><a href="http://www.walkingrandomly.com/?cat=12" >Science</a> (15)
</li>
	<li class="cat-item cat-item-67"><a href="http://www.walkingrandomly.com/?cat=67" >Scientific Software</a> (29)
</li>
	<li class="cat-item cat-item-64"><a href="http://www.walkingrandomly.com/?cat=64" >simulink</a> (2)
</li>
	<li class="cat-item cat-item-69"><a href="http://www.walkingrandomly.com/?cat=69" >software deployment</a> (6)
</li>
	<li class="cat-item cat-item-29"><a href="http://www.walkingrandomly.com/?cat=29" >Statistics</a> (4)
</li>
	<li class="cat-item cat-item-30"><a href="http://www.walkingrandomly.com/?cat=30" >The internet</a> (12)
</li>
	<li class="cat-item cat-item-23"><a href="http://www.walkingrandomly.com/?cat=23" >Travel</a> (5)
</li>
	<li class="cat-item cat-item-60"><a href="http://www.walkingrandomly.com/?cat=60" >trivia</a> (1)
</li>
	<li class="cat-item cat-item-42"><a href="http://www.walkingrandomly.com/?cat=42" >tutorials</a> (10)
</li>
	<li class="cat-item cat-item-1"><a href="http://www.walkingrandomly.com/?cat=1" >Uncategorized</a> (20)
</li>
	<li class="cat-item cat-item-79"><a href="http://www.walkingrandomly.com/?cat=79" >University of Sheffield</a> (7)
</li>
	<li class="cat-item cat-item-22"><a href="http://www.walkingrandomly.com/?cat=22" >Vacation</a> (2)
</li>
	<li class="cat-item cat-item-15"><a href="http://www.walkingrandomly.com/?cat=15" >walking randomly</a> (47)
</li>
	<li class="cat-item cat-item-66"><a href="http://www.walkingrandomly.com/?cat=66" >Windows</a> (9)
</li>
	<li class="cat-item cat-item-70"><a href="http://www.walkingrandomly.com/?cat=70" >Windows 8</a> (1)
</li>
	<li class="cat-item cat-item-33"><a href="http://www.walkingrandomly.com/?cat=33" >Wolfram Alpha</a> (18)
</li>
	<li class="cat-item cat-item-18"><a href="http://www.walkingrandomly.com/?cat=18" >Wolfram Demonstrations</a> (24)
</li>
		</ul>
</li><li class="widget widget_archive"><h3>Archives</h3>		<ul>
			<li><a href='http://www.walkingrandomly.com/?m=201701'>January 2017</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201612'>December 2016</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201610'>October 2016</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201609'>September 2016</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201608'>August 2016</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201607'>July 2016</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201606'>June 2016</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201605'>May 2016</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201604'>April 2016</a>&nbsp;(10)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201603'>March 2016</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201602'>February 2016</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201601'>January 2016</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201512'>December 2015</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201511'>November 2015</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201510'>October 2015</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201509'>September 2015</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201508'>August 2015</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201507'>July 2015</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201506'>June 2015</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201505'>May 2015</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201504'>April 2015</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201503'>March 2015</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201502'>February 2015</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201501'>January 2015</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201412'>December 2014</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201411'>November 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201410'>October 2014</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201409'>September 2014</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201408'>August 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201407'>July 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201406'>June 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201405'>May 2014</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201404'>April 2014</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201403'>March 2014</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201402'>February 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201401'>January 2014</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201312'>December 2013</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201311'>November 2013</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201310'>October 2013</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201309'>September 2013</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201308'>August 2013</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201307'>July 2013</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201306'>June 2013</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201305'>May 2013</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201304'>April 2013</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201303'>March 2013</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201302'>February 2013</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201301'>January 2013</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201212'>December 2012</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201211'>November 2012</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201210'>October 2012</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201209'>September 2012</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201208'>August 2012</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201207'>July 2012</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201206'>June 2012</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201205'>May 2012</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201204'>April 2012</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201203'>March 2012</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201202'>February 2012</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201201'>January 2012</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201112'>December 2011</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201110'>October 2011</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201109'>September 2011</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201108'>August 2011</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201107'>July 2011</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201106'>June 2011</a>&nbsp;(10)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201105'>May 2011</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201104'>April 2011</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201103'>March 2011</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201102'>February 2011</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201101'>January 2011</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201012'>December 2010</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201011'>November 2010</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201010'>October 2010</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201009'>September 2010</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201008'>August 2010</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201007'>July 2010</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201006'>June 2010</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201005'>May 2010</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201004'>April 2010</a>&nbsp;(9)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201003'>March 2010</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201002'>February 2010</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201001'>January 2010</a>&nbsp;(9)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200912'>December 2009</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200911'>November 2009</a>&nbsp;(10)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200910'>October 2009</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200909'>September 2009</a>&nbsp;(9)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200908'>August 2009</a>&nbsp;(16)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200907'>July 2009</a>&nbsp;(10)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200906'>June 2009</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200905'>May 2009</a>&nbsp;(19)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200904'>April 2009</a>&nbsp;(25)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200903'>March 2009</a>&nbsp;(14)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200902'>February 2009</a>&nbsp;(12)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200901'>January 2009</a>&nbsp;(14)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200812'>December 2008</a>&nbsp;(15)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200811'>November 2008</a>&nbsp;(15)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200810'>October 2008</a>&nbsp;(18)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200809'>September 2008</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200808'>August 2008</a>&nbsp;(15)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200807'>July 2008</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200806'>June 2008</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200805'>May 2008</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200804'>April 2008</a>&nbsp;(13)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200803'>March 2008</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200802'>February 2008</a>&nbsp;(14)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200801'>January 2008</a>&nbsp;(13)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200712'>December 2007</a>&nbsp;(9)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200711'>November 2007</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200710'>October 2007</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200709'>September 2007</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200708'>August 2007</a>&nbsp;(3)</li>
		</ul>
		</li><li class="widget widget_links"><h3>Blogroll</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://qchu.wordpress.com/">Annoying Precision</a></li>
<li><a href="http://myreckonings.com/wordpress/">Dead Reckonings</a></li>
<li><a href="http://gottwurfelt.wordpress.com/">God Plays dice</a></li>
<li><a href="http://letsplaymath.wordpress.com/">Let&#039;s play math</a></li>
<li><a href="http://mathnotations.blogspot.com/" title="http://mathnotations.blogspot.com/">Math Notations</a></li>
<li><a href="http://www.mathpuzzle.com/">Math Puzzles</a></li>
<li><a href="http://nickhigham.wordpress.com/">Nick Higham (Applied math)</a></li>
<li><a href="http://pleasemakeanote.blogspot.com/">PleaseMakeANote</a></li>
<li><a href="http://www.mathfinance.cn/">Quantitative Finance Collector</a></li>
<li><a href="http://www.terminally-incoherent.com/blog/">Terminally Incoherent</a></li>
<li><a href="http://www.johndcook.com/blog/">The Endeavour</a></li>
<li><a href="http://blog.plover.com/">The Universe of Discourse</a></li>

	</ul>
</li>
<li class="widget widget_meta"><h3>Meta</h3>			<ul>
						<li><a href="http://www.walkingrandomly.com/wp-login.php">Log in</a></li>
			<li><a href="http://www.walkingrandomly.com/?feed=rss2">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://www.walkingrandomly.com/?feed=comments-rss2">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</li>		</ul>

		<!-- showcase 2 -->
		
</div>
<!-- sidebar END -->

	<div class="fixed"></div>

		<div id="bottom">
			<div class="postnav">
				<span class="alignleft">&laquo; <a href="http://www.walkingrandomly.com/?p=1659" rel="prev">RationalQ &#8211; Testing for rationals in Mathematica</a></span>
				<span class="alignright"><a href="http://www.walkingrandomly.com/?p=1691" rel="next">NASA releases first images from upgraded Hubble</a> &raquo;</span>
				<div class="fixed"></div>
			</div>

			<div class="anchor">
				<span><a href="#" onclick="MGJS.goTop();return false;">TOP</a></span>
			</div>
			<div class="fixed"></div>
			</div>
		<div class="fixed"></div>
	</div>
</div>

<!-- footer START -->
<div id="footer">
	<div class="inner">
		<div class="content">
			<p id="about">
				Copyright &copy; 2007-2017 Walking Randomly | Powered by <a href="http://wordpress.org/">WordPress</a> | Theme by <a href="http://www.neoease.com/">NeoEase</a>			</p>

			<ul id="admin">
								<li><a href="http://www.walkingrandomly.com/wp-login.php">Log in</a></li>
			</ul>

			<div class="fixed"></div>
		</div>
	</div>
</div><!-- footer END --><!-- Powered by WPtouch: 4.3.8 -->	<div style="display:none">
	<div class="grofile-hash-map-3b782ebb44a9b498cdc6a37613e37db4">
	</div>
	<div class="grofile-hash-map-72cbc4e5d9b3369f5e2b5756353b9871">
	</div>
	<div class="grofile-hash-map-f169909e67458df9036075ad7b86931c">
	</div>
	<div class="grofile-hash-map-d41d8cd98f00b204e9800998ecf8427e">
	</div>
	<div class="grofile-hash-map-aaef40d908de2cea51dcad051641e182">
	</div>
	<div class="grofile-hash-map-21929783771d23c8f0e0d357416b61f4">
	</div>
	<div class="grofile-hash-map-8e726fbe83142bafc21f1bd83dc1a1d6">
	</div>
	<div class="grofile-hash-map-a1544738baf5de4bbd417764ed162986">
	</div>
	<div class="grofile-hash-map-49fd680821864abdcd55028f4db43578">
	</div>
	<div class="grofile-hash-map-25e82afd74880aa0771fd0b4443fb128">
	</div>
	<div class="grofile-hash-map-849e5800ec62a1a993bfd47a690b2c1d">
	</div>
	<div class="grofile-hash-map-9b762f1d87a29d9e2fda2677f7cb6112">
	</div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.walkingrandomly.com\/?p=1676":1676};
	</script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-content/plugins/akismet/_inc/form.js?ver=3.2'></script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-includes/js/comment-reply.min.js?ver=4.6.2'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201703'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Janaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.6.2'></script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-includes/js/wp-embed.min.js?ver=4.6.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.4.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript' src='http://stats.wp.com/e-201703.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.4.2',blog:'51126282',post:'1676',tz:'1',srv:'www.walkingrandomly.com'} ]);
	_stq.push([ 'clickTrackerInit', '51126282', '1676' ]);
</script>
<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try {
var pageTracker = _gat._getTracker("UA-15600688-1");
pageTracker._trackPageview();
} catch(err) {}</script>
</body>
</html>
