<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head profile="http://gmpg.org/xfn/11">
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

	<title>Walking Randomly &raquo; Meltdown and High Performance Computing</title>
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0 - all posts" href="http://feeds.feedburner.com/WalkingRandomly" />
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0 - all comments" href="http://www.walkingrandomly.com/?feed=comments-rss2" />
	<link rel="pingback" href="http://www.walkingrandomly.com/xmlrpc.php" />

	<!-- style START -->
	<link rel="stylesheet" href="http://www.walkingrandomly.com/wp-content/themes/elegant-box/style.css" type="text/css" media="screen" />
		<!--[if IE]>
		<link rel="stylesheet" href="http://www.walkingrandomly.com/wp-content/themes/elegant-box/ie.css" type="text/css" media="screen" />
	<![endif]-->

	<!-- default style -->
			<link rel="stylesheet" href="http://www.walkingrandomly.com/wp-content/themes/elegant-box/styles/blue/default.css" type="text/css" media="screen" title="blue" />
		<link rel="stylesheet" href="http://www.walkingrandomly.com/wp-content/themes/elegant-box/styles/blue/global.css" type="text/css" media="screen" />
	
	<!-- others styles -->
	<!-- style END -->

	<!-- javascript START -->
		<script type="text/javascript" src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/js/base.js"></script>
	<script type="text/javascript" src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/js/menu.js"></script>
	<!-- javascript END -->

		<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Walking Randomly &raquo; Meltdown and High Performance Computing Comments Feed" href="http://www.walkingrandomly.com/?feed=rss2&#038;p=6411" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.walkingrandomly.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.10"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-quicklatex-format-css'  href='http://www.walkingrandomly.com/wp-content/plugins/wp-quicklatex/css/quicklatex-format.css?ver=4.6.10' type='text/css' media='all' />
<link rel='stylesheet' id='wp-syntax-css-css'  href='http://www.walkingrandomly.com/wp-content/themes/elegant-box/wp-syntax.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='http://www.walkingrandomly.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.walkingrandomly.com/wp-content/plugins/jetpack/css/jetpack.css?ver=4.7.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-content/plugins/wp-quicklatex/js/wp-quicklatex-frontend.js?ver=1.0'></script>
<link rel='https://api.w.org/' href='http://www.walkingrandomly.com/?rest_route=/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.walkingrandomly.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.walkingrandomly.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Research Councils UK Cloud Workshop' href='http://www.walkingrandomly.com/?p=6406' />
<meta name="generator" content="WordPress 4.6.10" />
<link rel="canonical" href="http://www.walkingrandomly.com/?p=6411" />
<link rel='shortlink' href='http://wp.me/p3swhs-1Fp' />
<link rel="alternate" type="application/json+oembed" href="http://www.walkingrandomly.com/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.walkingrandomly.com%2F%3Fp%3D6411" />
<link rel="alternate" type="text/xml+oembed" href="http://www.walkingrandomly.com/?rest_route=%2Foembed%2F1.0%2Fembed&#038;url=http%3A%2F%2Fwww.walkingrandomly.com%2F%3Fp%3D6411&#038;format=xml" />
<style data-context="foundation-flickity-css">/*! Flickity v2.0.2
http://flickity.metafizzy.co
---------------------------------------------- */.flickity-enabled{position:relative}.flickity-enabled:focus{outline:0}.flickity-viewport{overflow:hidden;position:relative;height:100%}.flickity-slider{position:absolute;width:100%;height:100%}.flickity-enabled.is-draggable{-webkit-tap-highlight-color:transparent;tap-highlight-color:transparent;-webkit-user-select:none;-moz-user-select:none;-ms-user-select:none;user-select:none}.flickity-enabled.is-draggable .flickity-viewport{cursor:move;cursor:-webkit-grab;cursor:grab}.flickity-enabled.is-draggable .flickity-viewport.is-pointer-down{cursor:-webkit-grabbing;cursor:grabbing}.flickity-prev-next-button{position:absolute;top:50%;width:44px;height:44px;border:none;border-radius:50%;background:#fff;background:hsla(0,0%,100%,.75);cursor:pointer;-webkit-transform:translateY(-50%);transform:translateY(-50%)}.flickity-prev-next-button:hover{background:#fff}.flickity-prev-next-button:focus{outline:0;box-shadow:0 0 0 5px #09F}.flickity-prev-next-button:active{opacity:.6}.flickity-prev-next-button.previous{left:10px}.flickity-prev-next-button.next{right:10px}.flickity-rtl .flickity-prev-next-button.previous{left:auto;right:10px}.flickity-rtl .flickity-prev-next-button.next{right:auto;left:10px}.flickity-prev-next-button:disabled{opacity:.3;cursor:auto}.flickity-prev-next-button svg{position:absolute;left:20%;top:20%;width:60%;height:60%}.flickity-prev-next-button .arrow{fill:#333}.flickity-page-dots{position:absolute;width:100%;bottom:-25px;padding:0;margin:0;list-style:none;text-align:center;line-height:1}.flickity-rtl .flickity-page-dots{direction:rtl}.flickity-page-dots .dot{display:inline-block;width:10px;height:10px;margin:0 8px;background:#333;border-radius:50%;opacity:.25;cursor:pointer}.flickity-page-dots .dot.is-selected{opacity:1}</style><style data-context="foundation-slideout-css">.slideout-menu{position:fixed;left:0;top:0;bottom:0;right:auto;z-index:0;width:256px;overflow-y:auto;-webkit-overflow-scrolling:touch;display:none}.slideout-menu.pushit-right{left:auto;right:0}.slideout-panel{position:relative;z-index:1;will-change:transform}.slideout-open,.slideout-open .slideout-panel,.slideout-open body{overflow:hidden}.slideout-open .slideout-menu{display:block}.pushit{display:none}</style>
<link rel='dns-prefetch' href='//v0.wordpress.com'>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//s1.wp.com'>
<link rel='dns-prefetch' href='//s2.wp.com'>
<link rel='dns-prefetch' href='//public-api.wordpress.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Meltdown and High Performance Computing" />
<meta property="og:url" content="http://www.walkingrandomly.com/?p=6411" />
<meta property="og:description" content="The Meltdown bug which affects most modern CPUs has been called by some &#8216;The worst ever CPU bug&#8217;. Accessible explanations about what the Meltdown bug actually is are available here and …" />
<meta property="article:published_time" content="2018-02-10T09:47:48+00:00" />
<meta property="article:modified_time" content="2018-02-10T09:57:16+00:00" />
<meta property="og:site_name" content="Walking Randomly" />
<meta property="og:image" content="https://s0.wp.com/i/blank.jpg" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:card" content="summary" />
<style>.ios7.web-app-mode.has-fixed header{ background-color: rgba(3,122,221,.88);}</style></head>


<body>
	<!-- header START -->
	<div id="header">
		<div class="inner">
			<div class="content">
				<div class="caption">
					<h1 id="title"><a href="http://www.walkingrandomly.com/" title="Because it&#8217;s more fun than getting there in a straight line.">Walking Randomly</a></h1>
					<div id="tagline">Because it&#8217;s more fun than getting there in a straight line.</div>
				</div>

				<!-- search box -->
									<form action="http://www.walkingrandomly.com/" id="search_box" method="get">
						<div id="searchbox">
							<input type="text" id="searchtxt" class="textfield" name="s" value="" />
						</div>
					</form>
				<script type="text/javascript">
//<![CDATA[
	var searchbox = document.getElementById("searchbox");
	var searchtxt = document.getElementById("searchtxt");
	var tiptext = "Type text to search here...";
	if(searchtxt.value == "" || searchtxt.value == tiptext) {
		searchtxt.className += " searchtip";
		searchtxt.value = tiptext;
	}
	searchtxt.onfocus = function(e) {
		if(searchtxt.value == tiptext) {
			searchtxt.value = "";
			searchtxt.className = searchtxt.className.replace(" searchtip", "");
		}
	}
	searchtxt.onblur = function(e) {
		if(searchtxt.value == "") {
			searchtxt.className += " searchtip";
			searchtxt.value = tiptext;
		}
	}
//]]>
</script>

				<!-- navigation START -->
				<ul id="navigation">

					<li class="page_item"><a href="http://www.walkingrandomly.com/">Home</a></li>
					<li class="page_item page-item-2"><a href="http://www.walkingrandomly.com/?page_id=2">About Me</a></li>
<li class="page_item page-item-502"><a href="http://www.walkingrandomly.com/?page_id=502">Highlights</a></li>
<li class="page_item page-item-2055"><a href="http://www.walkingrandomly.com/?page_id=2055">Contact</a></li>
<li class="page_item page-item-5122"><a href="http://www.walkingrandomly.com/?page_id=5122">Testimonials</a></li>
					<li>
						<a rel="external nofollow" title="Follow me!" id="twitter" href="http://twitter.com/WalkingRandomly/"><img src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/images/transparent.gif" alt="Twitter" /></a>
					</li>
											<li id="subscribe">
						<a rel="external nofollow" title="Subscribe to this blog..." id="feed" href="http://feeds.feedburner.com/WalkingRandomly"><img src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/images/transparent.gif" alt="RSS feed" /></a>
					</li>

				</ul>
				<!-- navigation END -->

			</div>
		</div>
	</div>
	<!-- header END -->

	<div id="container">
		<div id="content">
			<div id="main">

		
			<div class="post">
				<div class="title">
					<h2>Meltdown and High Performance Computing</h2>
					<div class="fixed"></div>
				</div>

				<div class="info">
					
					<span>February 10th, 2018</span>
											<span> | Categories: <a href="http://www.walkingrandomly.com/?cat=86" rel="category">Cloud Computing</a>, <a href="http://www.walkingrandomly.com/?cat=68" rel="category">HPC</a>, <a href="http://www.walkingrandomly.com/?cat=41" rel="category">parallel programming</a></span>
																<span> | Tags: </span>
					
					<div class="fixed"></div>
				</div>

				<div class="content">
					<p>The <a href="https://en.wikipedia.org/wiki/Meltdown_(security_vulnerability)">Meltdown bug</a> which affects most modern CPUs has been called by some <a href="https://www.theguardian.com/technology/2018/jan/04/meltdown-spectre-worst-cpu-bugs-ever-found-affect-computers-intel-processors-security-flaw">&#8216;The worst ever CPU bug&#8217;</a>. Accessible explanations about what the Meltdown bug actually is are available <a href="https://www.facebook.com/Ozzard/posts/10157151940878975">here</a> and <a href="https://www.raspberrypi.org/blog/why-raspberry-pi-isnt-vulnerable-to-spectre-or-meltdown/">here</a>.</p>
<p>Software patches have been made available but some people have estimated a performance hit of up to 30% in some cases. Some of us in the High Performance Computing (HPC) community (See <a href="https://twitter.com/walkingrandomly/status/949230133243768835">here for the initial twitter conversation</a>) started to wonder what this might mean for the type of workloads that run on our systems. After all, if the worst case scenario of 30% is the norm, it will drastically affect the power of our systems and hence reduce the amount of science we are able to support.</p>
<p>In the video below, Professor Mark Handley of the <a href="https://www.turing.ac.uk/">Alan Turing Institute</a> gives a detailed explanation of both Meltdown and Spectre.</p>
<p><iframe src="https://www.youtube.com/embed/m66EAgRMmi8" width="560" height="315" frameborder="0" allowfullscreen="allowfullscreen"></iframe></p>
<p><strong>To patch or not to patch</strong><br />
To a first approximation, a patch causing a 30% performance hit on a system costing £1 million pounds is going to cost an equivalent of £300,000 &#8212; not exactly small change! This has led to some people wondering if we should patch HPC systems at all:</p>
<blockquote class="twitter-tweet" data-lang="en">
<p dir="ltr" lang="en">Given the size of the performance hit should we even *be* patching for this? Unless you need trusted computing, does it really matter for the average HPC?</p>
<p>— Phil Tooley (@acceleratedsci) <a href="https://twitter.com/acceleratedsci/status/949233180451713024?ref_src=twsrc%5Etfw">January 5, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>All of the UK Tier-3 HPC centres I&#8217;m aware of have applied the patches (Sheffield, Leeds and Manchester) but I&#8217;d be interested to learn of centres that decided not to.  Feel free to comment here or <a href="https://twitter.com/walkingrandomly">message me on twitter</a> if you have something to add to this discussion and I&#8217;ll update this post where appropriate.</p>
<p><strong>Research paper discussing the performance penalties of these patches on HPC workloads</strong></p>
<p>A group of people have written a paper on Arxiv that looks at HPC performance penalties in more detail.  From the paper&#8217;s abstract:</p>
<blockquote class="">
<div class="">
<div class="">The results show that although some specific functions can have execution times decreased by as much as 74%, the majority of individual metrics indicates little to no decrease in performance. The real-world applications show a 2-3% decrease in performance for single node jobs and a 5-11% decrease for parallel multi node jobs.</div>
</div>
</blockquote>
<div class="">The full pdf is available at <a href="https://arxiv.org/abs/1801.04329">https://arxiv.org/abs/1801.04329</a></div>
<p>&nbsp;</p>
<p><strong>Other relevant results and benchmarks</strong></p>
<p>Here are a few other links that discuss the performance penalty of applying the Meltdown patch.</p>
<ul>
<li><a href="https://access.redhat.com/articles/3307751">Redhat&#8217;s experiments</a> showing worst-case performance drops of 19% in certain benchmarks.</li>
<li><a href="https://en.wikipedia.org/wiki/Kernel_page-table_isolation#Implementation">Wikipedia article</a> showing a summary of various benchmarks.</li>
</ul>
<p><strong>Acknowledgements</strong></p>
<p>Thanks to Adrian Jackson, Phil Tooley, Filippo Spiga and members of the UK HPC-SIG for useful discussions.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-6411" class="share-twitter sd-button share-icon no-text" href="http://www.walkingrandomly.com/?p=6411&amp;share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-6411" class="share-facebook sd-button share-icon no-text" href="http://www.walkingrandomly.com/?p=6411&amp;share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-6411" class="share-google-plus-1 sd-button share-icon no-text" href="http://www.walkingrandomly.com/?p=6411&amp;share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>					<div class="fixed"></div>
				</div>

				<div class="comments comments_single">
					<a href="#respond">Leave a comment</a>
											 | <a href="http://www.walkingrandomly.com/wp-trackback.php?p=6411" rel="trackback">Trackback</a>
									</div>

				<!-- related posts START -->
								<!-- related posts END -->
			</div>


<script type="text/javascript" src="http://www.walkingrandomly.com/wp-content/themes/elegant-box/js/comment.js"></script>

	<div class="messagebox">
		<div class="content small">
			No comments yet.		</div>
	</div>


	<div id="respond">
	<form action="http://www.walkingrandomly.com/wp-comments-post.php" method="post" id="commentform">

	<!-- comment info -->
	<div id="comment_header">
		<div id="comment_info">
							
				<div id="author_info">
					<div class="row">
						<input type="text" name="author" id="author" class="textfield" value="" size="24" tabindex="1" />
						<label for="author" class="small">Name </label>
					</div>
					<div class="row">
						<input type="text" name="email" id="email" class="textfield" value="" size="24" tabindex="2" />
						<label for="email" class="small">E-Mail (will not be published) </label>
					</div>
					<div class="row">
						<input type="text" name="url" id="url" class="textfield" value="" size="24" tabindex="3" />
						<label for="url" class="small">Website</label>
					</div>
				</div>

				
					</div>
	</div>

	<!-- comment input -->
	<textarea name="comment" id="comment" tabindex="4" rows="8" cols="50"></textarea>

	<!-- comment submit and rss -->
	<div id="submitbox">
		<div id="comments_rss">
			<a href="http://www.walkingrandomly.com/?feed=comments-rss2">
				<span class="feed">Subscribe to comments feed</span>
			</a>
		</div>

		<div class="act">
							<a rel="nofollow" id="cancel-comment-reply-link" href="/?p=6411#respond" style="display:none;">Cancel</a>						<input name="submit" type="submit" id="submit" class="button" tabindex="5" value="Submit Comment" />
		</div>
		
		<input type="hidden" name="comment_post_ID" value="6411" />
					<input type='hidden' name='comment_post_ID' value='6411' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
				<div class="fixed"></div>
	</div>

	<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="9383956c34" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="151"/></p>	</form>
	</div>

	

			

	</div>

	<!-- sidebar START -->
<div id="sidebar">

<!-- Style Switcher START -->
<!-- Style Switcher END -->

		<!-- showcase -->
		
		<ul id="widgets">

<li class="widget widget_categories"><h3>Categories</h3>		<ul>
	<li class="cat-item cat-item-35"><a href="http://www.walkingrandomly.com/?cat=35" >Android</a> (15)
</li>
	<li class="cat-item cat-item-75"><a href="http://www.walkingrandomly.com/?cat=75" >Apple</a> (4)
</li>
	<li class="cat-item cat-item-20"><a href="http://www.walkingrandomly.com/?cat=20" >applications</a> (14)
</li>
	<li class="cat-item cat-item-38"><a href="http://www.walkingrandomly.com/?cat=38" >Books</a> (6)
</li>
	<li class="cat-item cat-item-65"><a href="http://www.walkingrandomly.com/?cat=65" >C/C++</a> (5)
</li>
	<li class="cat-item cat-item-37"><a href="http://www.walkingrandomly.com/?cat=37" >Carnival of Math</a> (25)
</li>
	<li class="cat-item cat-item-16"><a href="http://www.walkingrandomly.com/?cat=16" >Chemistry</a> (2)
</li>
	<li class="cat-item cat-item-86"><a href="http://www.walkingrandomly.com/?cat=86" >Cloud Computing</a> (3)
</li>
	<li class="cat-item cat-item-48"><a href="http://www.walkingrandomly.com/?cat=48" >Condor</a> (6)
</li>
	<li class="cat-item cat-item-71"><a href="http://www.walkingrandomly.com/?cat=71" >control theory</a> (2)
</li>
	<li class="cat-item cat-item-44"><a href="http://www.walkingrandomly.com/?cat=44" >CUDA</a> (13)
</li>
	<li class="cat-item cat-item-58"><a href="http://www.walkingrandomly.com/?cat=58" >Financial Math</a> (3)
</li>
	<li class="cat-item cat-item-34"><a href="http://www.walkingrandomly.com/?cat=34" >Fortran</a> (3)
</li>
	<li class="cat-item cat-item-46"><a href="http://www.walkingrandomly.com/?cat=46" >Fractals</a> (6)
</li>
	<li class="cat-item cat-item-40"><a href="http://www.walkingrandomly.com/?cat=40" >Free software</a> (14)
</li>
	<li class="cat-item cat-item-13"><a href="http://www.walkingrandomly.com/?cat=13" >games</a> (13)
</li>
	<li class="cat-item cat-item-6"><a href="http://www.walkingrandomly.com/?cat=6" >general math</a> (137)
</li>
	<li class="cat-item cat-item-51"><a href="http://www.walkingrandomly.com/?cat=51" >GPU</a> (17)
</li>
	<li class="cat-item cat-item-49"><a href="http://www.walkingrandomly.com/?cat=49" >Guest posts</a> (9)
</li>
	<li class="cat-item cat-item-68"><a href="http://www.walkingrandomly.com/?cat=68" >HPC</a> (13)
</li>
	<li class="cat-item cat-item-43"><a href="http://www.walkingrandomly.com/?cat=43" >iPad</a> (9)
</li>
	<li class="cat-item cat-item-27"><a href="http://www.walkingrandomly.com/?cat=27" >iPhone</a> (11)
</li>
	<li class="cat-item cat-item-14"><a href="http://www.walkingrandomly.com/?cat=14" >java</a> (3)
</li>
	<li class="cat-item cat-item-59"><a href="http://www.walkingrandomly.com/?cat=59" >Julia</a> (5)
</li>
	<li class="cat-item cat-item-45"><a href="http://www.walkingrandomly.com/?cat=45" >just for fun</a> (30)
</li>
	<li class="cat-item cat-item-3"><a href="http://www.walkingrandomly.com/?cat=3" >Latex</a> (5)
</li>
	<li class="cat-item cat-item-73"><a href="http://www.walkingrandomly.com/?cat=73" >Linear Algebra</a> (6)
</li>
	<li class="cat-item cat-item-5"><a href="http://www.walkingrandomly.com/?cat=5" >Linux</a> (40)
</li>
	<li class="cat-item cat-item-26"><a href="http://www.walkingrandomly.com/?cat=26" >Mac OS X</a> (8)
</li>
	<li class="cat-item cat-item-52"><a href="http://www.walkingrandomly.com/?cat=52" >Making Mathematica Faster</a> (2)
</li>
	<li class="cat-item cat-item-53"><a href="http://www.walkingrandomly.com/?cat=53" >Making MATLAB faster</a> (16)
</li>
	<li class="cat-item cat-item-25"><a href="http://www.walkingrandomly.com/?cat=25" >Maple</a> (23)
</li>
	<li class="cat-item cat-item-4"><a href="http://www.walkingrandomly.com/?cat=4" >math software</a> (217)
</li>
	<li class="cat-item cat-item-17"><a href="http://www.walkingrandomly.com/?cat=17" >mathcad</a> (16)
</li>
	<li class="cat-item cat-item-8"><a href="http://www.walkingrandomly.com/?cat=8" >mathematica</a> (105)
</li>
	<li class="cat-item cat-item-11"><a href="http://www.walkingrandomly.com/?cat=11" >matlab</a> (136)
</li>
	<li class="cat-item cat-item-39"><a href="http://www.walkingrandomly.com/?cat=39" >Maxima</a> (2)
</li>
	<li class="cat-item cat-item-56"><a href="http://www.walkingrandomly.com/?cat=56" >Microsoft</a> (3)
</li>
	<li class="cat-item cat-item-55"><a href="http://www.walkingrandomly.com/?cat=55" >Mobile Mathematics</a> (15)
</li>
	<li class="cat-item cat-item-47"><a href="http://www.walkingrandomly.com/?cat=47" >Month of Math Software</a> (30)
</li>
	<li class="cat-item cat-item-28"><a href="http://www.walkingrandomly.com/?cat=28" >NAG Library</a> (32)
</li>
	<li class="cat-item cat-item-61"><a href="http://www.walkingrandomly.com/?cat=61" >natural language</a> (2)
</li>
	<li class="cat-item cat-item-76"><a href="http://www.walkingrandomly.com/?cat=76" >Numerics</a> (3)
</li>
	<li class="cat-item cat-item-78"><a href="http://www.walkingrandomly.com/?cat=78" >Open Data Science</a> (7)
</li>
	<li class="cat-item cat-item-32"><a href="http://www.walkingrandomly.com/?cat=32" >Open Source</a> (23)
</li>
	<li class="cat-item cat-item-50"><a href="http://www.walkingrandomly.com/?cat=50" >OpenCL</a> (5)
</li>
	<li class="cat-item cat-item-41"><a href="http://www.walkingrandomly.com/?cat=41" >parallel programming</a> (21)
</li>
	<li class="cat-item cat-item-19"><a href="http://www.walkingrandomly.com/?cat=19" >physics</a> (9)
</li>
	<li class="cat-item cat-item-9"><a href="http://www.walkingrandomly.com/?cat=9" >pocket pc</a> (9)
</li>
	<li class="cat-item cat-item-72"><a href="http://www.walkingrandomly.com/?cat=72" >Powershell</a> (1)
</li>
	<li class="cat-item cat-item-54"><a href="http://www.walkingrandomly.com/?cat=54" >probability</a> (1)
</li>
	<li class="cat-item cat-item-21"><a href="http://www.walkingrandomly.com/?cat=21" >Problem of the week</a> (12)
</li>
	<li class="cat-item cat-item-7"><a href="http://www.walkingrandomly.com/?cat=7" >programming</a> (153)
</li>
	<li class="cat-item cat-item-31"><a href="http://www.walkingrandomly.com/?cat=31" >python</a> (44)
</li>
	<li class="cat-item cat-item-36"><a href="http://www.walkingrandomly.com/?cat=36" >R</a> (16)
</li>
	<li class="cat-item cat-item-63"><a href="http://www.walkingrandomly.com/?cat=63" >random numbers</a> (7)
</li>
	<li class="cat-item cat-item-74"><a href="http://www.walkingrandomly.com/?cat=74" >raspberry pi</a> (1)
</li>
	<li class="cat-item cat-item-10"><a href="http://www.walkingrandomly.com/?cat=10" >retro computers</a> (6)
</li>
	<li class="cat-item cat-item-80"><a href="http://www.walkingrandomly.com/?cat=80" >RSE</a> (35)
</li>
	<li class="cat-item cat-item-24"><a href="http://www.walkingrandomly.com/?cat=24" >sage interactions</a> (13)
</li>
	<li class="cat-item cat-item-12"><a href="http://www.walkingrandomly.com/?cat=12" >Science</a> (16)
</li>
	<li class="cat-item cat-item-67"><a href="http://www.walkingrandomly.com/?cat=67" >Scientific Software</a> (31)
</li>
	<li class="cat-item cat-item-64"><a href="http://www.walkingrandomly.com/?cat=64" >simulink</a> (2)
</li>
	<li class="cat-item cat-item-69"><a href="http://www.walkingrandomly.com/?cat=69" >software deployment</a> (6)
</li>
	<li class="cat-item cat-item-29"><a href="http://www.walkingrandomly.com/?cat=29" >Statistics</a> (4)
</li>
	<li class="cat-item cat-item-30"><a href="http://www.walkingrandomly.com/?cat=30" >The internet</a> (12)
</li>
	<li class="cat-item cat-item-23"><a href="http://www.walkingrandomly.com/?cat=23" >Travel</a> (5)
</li>
	<li class="cat-item cat-item-60"><a href="http://www.walkingrandomly.com/?cat=60" >trivia</a> (1)
</li>
	<li class="cat-item cat-item-42"><a href="http://www.walkingrandomly.com/?cat=42" >tutorials</a> (11)
</li>
	<li class="cat-item cat-item-1"><a href="http://www.walkingrandomly.com/?cat=1" >Uncategorized</a> (20)
</li>
	<li class="cat-item cat-item-79"><a href="http://www.walkingrandomly.com/?cat=79" >University of Sheffield</a> (7)
</li>
	<li class="cat-item cat-item-22"><a href="http://www.walkingrandomly.com/?cat=22" >Vacation</a> (2)
</li>
	<li class="cat-item cat-item-15"><a href="http://www.walkingrandomly.com/?cat=15" >walking randomly</a> (49)
</li>
	<li class="cat-item cat-item-66"><a href="http://www.walkingrandomly.com/?cat=66" >Windows</a> (10)
</li>
	<li class="cat-item cat-item-70"><a href="http://www.walkingrandomly.com/?cat=70" >Windows 8</a> (1)
</li>
	<li class="cat-item cat-item-33"><a href="http://www.walkingrandomly.com/?cat=33" >Wolfram Alpha</a> (18)
</li>
	<li class="cat-item cat-item-18"><a href="http://www.walkingrandomly.com/?cat=18" >Wolfram Demonstrations</a> (24)
</li>
		</ul>
</li><li class="widget widget_archive"><h3>Archives</h3>		<ul>
			<li><a href='http://www.walkingrandomly.com/?m=201802'>February 2018</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201711'>November 2017</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201705'>May 2017</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201704'>April 2017</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201703'>March 2017</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201702'>February 2017</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201701'>January 2017</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201612'>December 2016</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201610'>October 2016</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201609'>September 2016</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201608'>August 2016</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201607'>July 2016</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201606'>June 2016</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201605'>May 2016</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201604'>April 2016</a>&nbsp;(10)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201603'>March 2016</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201602'>February 2016</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201601'>January 2016</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201512'>December 2015</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201511'>November 2015</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201510'>October 2015</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201509'>September 2015</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201508'>August 2015</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201507'>July 2015</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201506'>June 2015</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201505'>May 2015</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201504'>April 2015</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201503'>March 2015</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201502'>February 2015</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201501'>January 2015</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201412'>December 2014</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201411'>November 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201410'>October 2014</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201409'>September 2014</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201408'>August 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201407'>July 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201406'>June 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201405'>May 2014</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201404'>April 2014</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201403'>March 2014</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201402'>February 2014</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201401'>January 2014</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201312'>December 2013</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201311'>November 2013</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201310'>October 2013</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201309'>September 2013</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201308'>August 2013</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201307'>July 2013</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201306'>June 2013</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201305'>May 2013</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201304'>April 2013</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201303'>March 2013</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201302'>February 2013</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201301'>January 2013</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201212'>December 2012</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201211'>November 2012</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201210'>October 2012</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201209'>September 2012</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201208'>August 2012</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201207'>July 2012</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201206'>June 2012</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201205'>May 2012</a>&nbsp;(2)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201204'>April 2012</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201203'>March 2012</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201202'>February 2012</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201201'>January 2012</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201112'>December 2011</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201110'>October 2011</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201109'>September 2011</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201108'>August 2011</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201107'>July 2011</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201106'>June 2011</a>&nbsp;(10)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201105'>May 2011</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201104'>April 2011</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201103'>March 2011</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201102'>February 2011</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201101'>January 2011</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201012'>December 2010</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201011'>November 2010</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201010'>October 2010</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201009'>September 2010</a>&nbsp;(5)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201008'>August 2010</a>&nbsp;(1)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201007'>July 2010</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201006'>June 2010</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201005'>May 2010</a>&nbsp;(3)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201004'>April 2010</a>&nbsp;(9)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201003'>March 2010</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201002'>February 2010</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=201001'>January 2010</a>&nbsp;(9)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200912'>December 2009</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200911'>November 2009</a>&nbsp;(10)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200910'>October 2009</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200909'>September 2009</a>&nbsp;(9)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200908'>August 2009</a>&nbsp;(16)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200907'>July 2009</a>&nbsp;(10)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200906'>June 2009</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200905'>May 2009</a>&nbsp;(19)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200904'>April 2009</a>&nbsp;(25)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200903'>March 2009</a>&nbsp;(14)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200902'>February 2009</a>&nbsp;(12)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200901'>January 2009</a>&nbsp;(14)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200812'>December 2008</a>&nbsp;(15)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200811'>November 2008</a>&nbsp;(15)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200810'>October 2008</a>&nbsp;(18)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200809'>September 2008</a>&nbsp;(7)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200808'>August 2008</a>&nbsp;(15)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200807'>July 2008</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200806'>June 2008</a>&nbsp;(8)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200805'>May 2008</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200804'>April 2008</a>&nbsp;(13)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200803'>March 2008</a>&nbsp;(11)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200802'>February 2008</a>&nbsp;(14)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200801'>January 2008</a>&nbsp;(13)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200712'>December 2007</a>&nbsp;(9)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200711'>November 2007</a>&nbsp;(4)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200710'>October 2007</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200709'>September 2007</a>&nbsp;(6)</li>
	<li><a href='http://www.walkingrandomly.com/?m=200708'>August 2007</a>&nbsp;(3)</li>
		</ul>
		</li><li class="widget widget_links"><h3>Blogroll</h3>
	<ul class='xoxo blogroll'>
<li><a href="http://qchu.wordpress.com/">Annoying Precision</a></li>
<li><a href="http://myreckonings.com/wordpress/">Dead Reckonings</a></li>
<li><a href="http://gottwurfelt.wordpress.com/">God Plays dice</a></li>
<li><a href="http://letsplaymath.wordpress.com/">Let&#039;s play math</a></li>
<li><a href="http://mathnotations.blogspot.com/" title="http://mathnotations.blogspot.com/">Math Notations</a></li>
<li><a href="http://www.mathpuzzle.com/">Math Puzzles</a></li>
<li><a href="http://nickhigham.wordpress.com/">Nick Higham (Applied math)</a></li>
<li><a href="http://pleasemakeanote.blogspot.com/">PleaseMakeANote</a></li>
<li><a href="http://www.mathfinance.cn/">Quantitative Finance Collector</a></li>
<li><a href="http://www.terminally-incoherent.com/blog/">Terminally Incoherent</a></li>
<li><a href="http://www.johndcook.com/blog/">The Endeavour</a></li>
<li><a href="http://blog.plover.com/">The Universe of Discourse</a></li>

	</ul>
</li>
<li class="widget widget_meta"><h3>Meta</h3>			<ul>
						<li><a href="http://www.walkingrandomly.com/wp-login.php">Log in</a></li>
			<li><a href="http://www.walkingrandomly.com/?feed=rss2">Entries <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="http://www.walkingrandomly.com/?feed=comments-rss2">Comments <abbr title="Really Simple Syndication">RSS</abbr></a></li>
			<li><a href="https://wordpress.org/" title="Powered by WordPress, state-of-the-art semantic personal publishing platform.">WordPress.org</a></li>			</ul>
			</li>		</ul>

		<!-- showcase 2 -->
		
</div>
<!-- sidebar END -->

	<div class="fixed"></div>

		<div id="bottom">
			<div class="postnav">
				<span class="alignleft">&laquo; <a href="http://www.walkingrandomly.com/?p=6406" rel="prev">Research Councils UK Cloud Workshop</a></span>
				<span class="alignright"></span>
				<div class="fixed"></div>
			</div>

			<div class="anchor">
				<span><a href="#" onclick="MGJS.goTop();return false;">TOP</a></span>
			</div>
			<div class="fixed"></div>
			</div>
		<div class="fixed"></div>
	</div>
</div>

<!-- footer START -->
<div id="footer">
	<div class="inner">
		<div class="content">
			<p id="about">
				Copyright &copy; 2007-2018 Walking Randomly | Powered by <a href="http://wordpress.org/">WordPress</a> | Theme by <a href="http://www.neoease.com/">NeoEase</a>			</p>

			<ul id="admin">
								<li><a href="http://www.walkingrandomly.com/wp-login.php">Log in</a></li>
			</ul>

			<div class="fixed"></div>
		</div>
	</div>
</div><!-- footer END --><!-- Powered by WPtouch: 4.3.13.1 -->	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/www.walkingrandomly.com\/?p=6411":6411};
	</script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3'></script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-includes/js/comment-reply.min.js?ver=4.6.10'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201806'></script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-content/plugins/wp-syntax/js/wp-syntax.js?ver=1.1'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2018Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.6.10'></script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-includes/js/wp-embed.min.js?ver=4.6.10'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.walkingrandomly.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=4.7.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201806.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.7.1',blog:'51126282',post:'6411',tz:'1',srv:'www.walkingrandomly.com'} ]);
	_stq.push([ 'clickTrackerInit', '51126282', '6411' ]);
</script>
<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try {
var pageTracker = _gat._getTracker("UA-15600688-1");
pageTracker._trackPageview();
} catch(err) {}</script>
</body>
</html>
